White magic pro 1900 surging pressure gauge

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Oct 29, 2015
6
0
1
Real Name
Cory Chessher
#1
I recently purchased this used van and I am enjoying the machine, however SOMETIMES the pressure surges on the gauge. The hose will also shake but when you use any cleaning tool the water comes out smooth. When it surges I turn it down to around 250 and it will stop, then wait a little and slowly turn it back up and it will usually stop. My main concern is of course this problem escalating and me ending up on a job that I can't finish. Any tips or tricks that I should look into? It may or may not be relevant to note the previous owner has removed the chemical feed system as he said the diaphragm blew too often. Thank you in advance, Cory
 

Attachments

JDARNOLD

Active Member
Jul 31, 2012
214
73
28
56
Real Name
Edward Arnold
Business Location
United States
#2
Sounds like it is the unloader valve. Should show 0 psi untilyou trigger the wand. But if you have any water leaks it will do that, because if the wand drips q connect leaks any water movement can cause it to jump the psi Guage up and down. If you are not feeling it at the wand I wouldn'tbe to worried about it.
 

smart n kleen

Smart N Kleen
Premium VIP
Mar 12, 2010
9,111
2,800
113
oregon
Real Name
Rick K
Business Location
United States
#3
Check the hoses going to and from the chemical meter. Any air leaks anywhere will cause Surging
 

ron Tabb

Active Member
Sep 13, 2015
135
47
28
51
Real Name
Ron Tabb
#4
if its not the unloader you have something stuck in your outlet valve of the pump easy fix