White Magic 1200HP shutting down/overheating | TruckMount Forums #1 Carpet Cleaning Forums

White Magic 1200HP shutting down/overheating

Sep 4, 2010
35
3
8
Real Name
Keith Miller
Business Location
United States
I have a White Magic 1200HP (2008) direct drive. The last 2 days it keeps shutting down on me. It works for about the first 30mins to and hour and then it shuts down. I let it cool for 5-15 mins and try again. It will work for 10-20 mins and then shut down again. It just keeps doing that the rest of the day. I have called Saphire to see if they have any suggestions but to no avail.

Took it to my mechanic who usually works on it (not a specialist) and he ran it for 45 mins without any problems.

ANY suggestions are welcome.

A BIG thank you in advance.
 

Jimmy L

Well-Known Member
Apr 16, 2012
1,333
362
83
Ne
Real Name
Jimmy Ladigwag
Business Location
United States
Van's fan clutch
 

JD5150

Well-Known Member
Oct 24, 2010
2,318
967
113
Real Name
JD S
Business Location
United States
Something to think about. Does the mechanic put a load on the machine and van like you do when cleaning?
Seems crazy it runs 45 minutes without problems with the mechanic runs it.
 
  • Like
Reactions: rob allen
Sep 4, 2010
35
3
8
Real Name
Keith Miller
Business Location
United States
The clutch was replaced about 2.5-3 yrs ago (before I bought it)
 
Sep 4, 2010
35
3
8
Real Name
Keith Miller
Business Location
United States
Machine has 3500 hrs on it. Clutch have was replaced between 1500-2000 hrs.
 

JD5150

Well-Known Member
Oct 24, 2010
2,318
967
113
Real Name
JD S
Business Location
United States
I do not like heat exchange machines but that is just me. Have you lost any suction? I would look at the blower exhaust silencer or blower heat exchanger if it has one. Might be shutting down from over heating blower heat exchanger because silencer or blower outlet flow plugging up. Just a thought I might be over thinking it.

I have had this happen on a air cooled engine. Blower silencer went to crap and caused engine overload and over heating. Once removed all was good but loud as hell until new silencer got here from shipment.
 
Sep 4, 2010
35
3
8
Real Name
Keith Miller
Business Location
United States
Didn't seem to lose suction. The red kill light comes on and it shuts down.
 

Wec

Active Member
Jul 31, 2012
563
131
43
43
Real Name
dustin denton
Is it building up to much heat on the pump side or is the engine coolant get to hot
 

Jimmy L

Well-Known Member
Apr 16, 2012
1,333
362
83
Ne
Real Name
Jimmy Ladigwag
Business Location
United States
Well if the mechanic had the hood open when running it for 45 min it wouldn't over heat in that time. While I have a different brand than WM it happened to me with the van's fan clutch.
 
  • Like
Reactions: rob allen
Sep 4, 2010
35
3
8
Real Name
Keith Miller
Business Location
United States
So it's on the pump side. Could it be my solutions hoses are a little clogged and they are putting some back pressure on the pump? I've had them for a little over 2 years.

Also - Put a blower facing the radiator on the van and it seemed to fix it. Weird right? Thoughts? Ideas?
 

rob allen

Administrator
Staff member
Administrator
Sep 5, 2007
35,635
18,033
113
Va.
www.drynclean.com
Real Name
Robert Allen,Jr.
Business Location
United States
How about changing the van thermostat and installing a new radiator cap?
 
  • Like
Reactions: Dirty dog paws