Specials Truckmount will not stay running when we flip ON the pump switch??

Jay007

New Member
Apr 6, 2021
2
0
1
Real Name
John Gonzalez
Hi, im very new to all of this so plz plz bear with me. Okay so we're using this "thermalwave blueline" machine and as the title says the machine will turn on but the moment I flip the pump switch ON the truckmount just shuts off after a few seconds. We have already changed the oils, check the filters, dumped all water from waste tank, replaced a bad valve because it was overheating and smoking but still nothing, the machine just will not stay on. I have done research all I keep finding is I might have a low pressure sensor problem. So does anyone think based on what I described that it is a low pressure sensor?? And if so how do I find or test this part?? Thanknyou for taking the time to read threw this.
 

Attachments

  • 16177247514729178951855323935343.jpg
    16177247514729178951855323935343.jpg
    68 KB · Views: 35
  • 16177247780051406992728922942449.jpg
    16177247780051406992728922942449.jpg
    54.2 KB · Views: 34
  • 16177248168545546101895849709038.jpg
    16177248168545546101895849709038.jpg
    62.1 KB · Views: 33
  • 1617724859893829343377708964658.jpg
    1617724859893829343377708964658.jpg
    59.9 KB · Views: 34

Justin Legend Brands

Expert Truckmount Mechanic
May 7, 2018
54
33
18
Real Name
Justin Johnston
Sounds like a low or high pressure switch to me. Make sure you have water in the water box, unplug them both and plug the connectors on the machine harness into each other. If the machine stays running when you do this, it will be a high or low pressure switch (most likely low pressure).
 
  • Like
Reactions: Jay007

Jay007

New Member
Apr 6, 2021
2
0
1
Real Name
John Gonzalez
Thanknyou for your time and response. Okay so I unplugged the high low sensors and connected together as instructed to check if it high or low sensor problem. The machine does not turn on and in turn pops the fuse so does mean there is short some where in the wiring??
 

Justin Legend Brands

Expert Truckmount Mechanic
May 7, 2018
54
33
18
Real Name
Justin Johnston
Thanknyou for your time and response. Okay so I unplugged the high low sensors and connected together as instructed to check if it high or low sensor problem. The machine does not turn on and in turn pops the fuse so does mean there is short some where in the wiring??
Yes if it pops the breaker, then there is a short somewhere in the wiring.