Tapping noise coming from heat exchanger Prochem apex | TruckMount Forums #1 Carpet Cleaning Forums

Tapping noise coming from heat exchanger Prochem apex

james n

Member
Mar 14, 2009
126
12
18
United States
Real Name
james niwinski
Business Location
United States
Machine is 10 years old with about 8000 hours. I recently have been hearing a tapping noise coming from the right lower side. It seems to be coming from the heat exchanger area. I know it could be a few things but before I start pulling all the heat exchangers I figured I’d see if anyone has some advice as to what it might be. It definitely is noticeable when it’s warming up idling. Not so much at full throttle. Thanks for any help.
 

Ara Klujian

Moderator & TMF Repair Expert
Moderator
Premium VIP
Jun 19, 2008
3,302
242
63
44
Chicago, IL
www.peterklujiancarpet.com
Real Name
ARA KLUJIAN
Business Location
United States
Maybe its the shroud tapping because its loose or bent. Place your hand over the covers to hold it in place and see if it stops. I wouldn't remove anything unless you are absolutely certain what it is. Another thing you can do is get a mechanics stethoscope and place it at certain points of interest to locate the noise. Old timers hold a long screwdriver up to ears and listen. Harbor freight has stethoscopes real cheap. hope this helps
 
  • Like
Reactions: TLC CARPET CLEANING

james n

Member
Mar 14, 2009
126
12
18
United States
Real Name
james niwinski
Business Location
United States
Maybe its the shroud tapping because its loose or bent. Place your hand over the covers to hold it in place and see if it stops. I wouldn't remove anything unless you are absolutely certain what it is. Another thing you can do is get a mechanics stethoscope and place it at certain points of interest to locate the noise. Old timers hold a long screwdriver up to ears and listen. Harbor freight has stethoscopes real cheap. hope this helps
It’s been awhile since I posted this and I have noticed there are orange seals around the heat exchangers and was thinking there could be a leak coming from them. I remember cracking 1 of my heat exchangers and had to bypass 1. When I took it out and ran it It was a lot louder and the noise seemed similar to my problem now. I’m gonna Check those seals. Thank you for responding