Suction comes and goes on my performer 405 | TruckMount Forums #1 Carpet Cleaning Forums

Suction comes and goes on my performer 405

GRLaw

New Member
Jul 19, 2018
3
1
1
Real Name
Gregg Lawrence
My Performer 405 loses suction for about 30 minutes and then it slowly comes back. It has happened now about 3 times, but only on larger jobs of 4-5 rooms or more. It will be going fine, and then over the span of about 1 minute, the suction goes from full to almost nothing. I empty the tank, check the seals, clean the inline filter, and no change. Each time, I've had to wait about 30 minutes for it, and then it will gradually increase back to full over then spam of about 2-3 minutes. Any ideas as to whats going on?
 

Todd the Cleaner

Todd Cottino
Premium VIP
Sep 4, 2011
22,952
15,111
113
50
Pahrump, Nevada, United States
www.toddscleaningservice.com
Real Name
Todd Cottino
Business Location
United States
Excessive foam in the hoses can cause loss of suction like that, but usually the suction will come back after a couple minutes (as long as you are not still cleaning)

Try keeping some defoamer with you. Next time this happens put some defoamer into your vac hose and see if suction returns.
 
  • Like
Reactions: JDARNOLD

GRLaw

New Member
Jul 19, 2018
3
1
1
Real Name
Gregg Lawrence
I forgot to mention that. I've tried using defoamer. I've put it in the tank, and through the hose. No change. It makes no sense.
 

crash1big

Well-Known Member
Mar 18, 2011
4,258
2,009
113
Illinois
Real Name
Marlan Brown
Business Location
United States
I forgot to mention that. I've tried using defoamer. I've put it in the tank, and through the hose. No change. It makes no sense.
Have you checked the vacuum relief? Maybe it is sticky.
 

ccclean

Active Member
Mar 12, 2016
228
106
43
Real Name
Stephen Boisvert
I think something is just blocked or the filter is getting water bound.
 

crash1big

Well-Known Member
Mar 18, 2011
4,258
2,009
113
Illinois
Real Name
Marlan Brown
Business Location
United States
What is the vacuum relief and how do i check it?
images

Its between the blower and waste tank. Use WD40 and spray it with the vacuum ports covered. Might loosen it up. That spring could also be worn out.
 

Justin Legend Brands

Expert Truckmount Mechanic
May 7, 2018
54
33
18
Real Name
Justin Johnston
Check the vacuum relief, and check the belts. The belts could be stretched and slipping.
 
  • Like
Reactions: JDARNOLD

Rory henderson

Active Member
Sep 22, 2015
363
189
43
48
Real Name
Rory henderson
probably waste tank gasket.....might have a leak & can't hear it with the machine on....that's what happen to me
 

Zarz

Well-Known Member
Feb 1, 2012
626
346
63
Victoria
Real Name
John Zahra
Business Location
Australia
Is the performer belt driven from engine to blower? maybe your belts are slipping and you need to retension or change?
 

SRD

Well-Known Member
Nov 6, 2010
4,970
3,958
113
midwest
Real Name
Spencer Dawdy
Business Location
United States
The suction coming and going like that makes me think as stated above the belts are slipping.
 

ToddBenne

Active Member
Sep 7, 2008
542
224
43
O' fallon, MO.
Real Name
Todd Benne
I am having similar symptoms with my ProChem Blazer. It has been going on for a few weeks.

On initial startup, the unit has almost no vacuum. Then, after the unit runs for a bit, and the wand is moving across the carpet, it attains I would guesstimate about 80-90% of full vacuum and you can clean. However, if you stop moving the wand to pre spray a room or move furniture for any length of time, the vacuum slowly decreases to almost zero again and increases back up once you start cleaning again.

Also, you can hear it sucking air throw the vac relief until it builds up to full vacuum. Almost as if it is under too much pressure and needs to relieve itself constantly.

I have adjusted the vac relief spring, replaced the vac relief diaphragm, replaced the waste tank seal, pull a decent chunk of hairball/fuzzball out of the vacuum inlet tube on the machine. Unit is running at full rpm, good heat, no vacuum obstructions that I have found.

https://shop.truckmountforums.com suggested pulling the heater core and checking for carbon and gunk build up. If found, have a radiator shop boil it, check for leaks and re install. I will do that in the next couple of days. J-D recommends doing this every 1000 hours too.

Local Denver-Gardner/Sutorbilt facility said if the bower is spinning, it is moving air there must be an obstruction.

Ideas?
 

Anderson

Well-Known Member
Aug 16, 2006
2,971
1,239
113
62
Belton Texas
wow interesting

just had a guy used to work for steambrite....tell me last week

if you have a larger tank or any tank and long hose runs!!!!...and you pull up the wand...
it takes 30-60 seconds for the vacuum to recover the suction..depending on hose length

as the air has to suction the hose and the tank air out when the wand is down.....

i didnt really take him serious but this looks like the problem you guys are describing
apparently he has done extensive testing on this...

i believe this could be the problem....

possible solutions:
get a bonzer or zipper that stays on the ground...
change out your vac relief to continual flow valve(water faucet handle).Rob has a video on this

also have heard of guys having no vac relief...supposed to increase massive lift and vacuum???

i question the vacuum relief issue????
i guess it is supposed safeguard blower or increas blower life?????
 

Jim Davisson

Well-Known Member
Aug 23, 2016
4,386
5,307
113
Serving the greater Charlotte area
Real Name
James Davisson
Business Location
United States
Assuming the blower is spinning at preferred RPM, pull the blower filter inside the recovery tank and run it across all RPMs. Does it have full vacuum at all ranges? Check with your hand... carefully. If yes, put the filter on and do the same thing on the vac hose barb with the recovery tank lid on. If it's not the same, do you have leaks in the tank itself above the water line or below the waterline?

If you are venting with the lid off, it could be a delaminated hose between the blower and tank, had that happen once from heat.

Vacuum should not come and go.
 

Anderson

Well-Known Member
Aug 16, 2006
2,971
1,239
113
62
Belton Texas
ii got rid of my micro filter inside my tank and only use an esternal filter....
seems to increase vacuum quiet a bit.......
 

Todd the Cleaner

Todd Cottino
Premium VIP
Sep 4, 2011
22,952
15,111
113
50
Pahrump, Nevada, United States
www.toddscleaningservice.com
Real Name
Todd Cottino
Business Location
United States
ii got rid of my micro filter inside my tank and only use an esternal filter....
seems to increase vacuum quiet a bit.......

Are you talking about the blower filter? If so I’d put that back in ASAP. Pull it out every 2 weeks and Clean it with muriatic acid and you will have good airflow. It’s amazing the difference the acid makes for the airflow.

B6309C6D-47DF-4093-8E91-3D1B7C6BB39A.jpeg
 

igare

Active Member
Mar 3, 2015
148
43
28
56
Chicago
www.arevalobroschemdrychicago.com
Real Name
Ignacio Arevalo
Business Location
United States
Are you talking about the blower filter? If so I’d put that back in ASAP. Pull it out every 2 weeks and Clean it with muriatic acid and you will have good airflow. It’s amazing the difference the acid makes for the airflow.

View attachment 80147

What does muriatic acid do the cleaning of filter tood?
 

Kyle8

Well-Known Member
Oct 22, 2016
2,013
565
113
36
Real Name
Kyle manor
Definitely could be foam in tank. Or belt slipping maybe. Check the lid gaskets to
 

Todd the Cleaner

Todd Cottino
Premium VIP
Sep 4, 2011
22,952
15,111
113
50
Pahrump, Nevada, United States
www.toddscleaningservice.com
Real Name
Todd Cottino
Business Location
United States
What does muriatic acid do the cleaning of filter tood?

It removes all the microscopic hard water and soap residue that builds up on the filter. You can’t see it but it’s there. Try it, you will notice an increase in airflow. I use The works toilet bowl cleaner that you can pick up for a dollar at the dollar store. Clean all the hair and lint off the filter first then put the acid on and clean it again.

323E2741-7438-4339-8F22-C18541CFE151.png
 
Jun 23, 2009
6
2
3
MISSOURI
Real Name
larry mcreynolds
Business Location
United States
Make sure you put the waste tank lid on the same way you take it off. My mechanic told me he’s seen that cause loss of cfm.