SS Apex 570 Throttle cable issue

Lc17smp

Member
Sep 19, 2019
44
19
8
Real Name
Larry Cole
Heads up if you have a SS Apex 570. My throttle started feeling strange over the last 2 weeks. I was doing maintenance today and found my throttle cable was melted and completely came apart. The cable didn’t come loose and was still in the factory position and guides. I spoke to someone at SS and he was aware of the issue. Apparently the newer 570’s have the cable routed up higher. I was advised to not route the new cable that I get to purchase in the factory position but rather higher up and away from the exhaust. JD only wants $170 for the new cable. Fortunately I found the exact oem cable for $58. Here is a pic.

45EED9BC-DBA9-4B2B-B2D9-CCE72B1F7073.jpeg
 

Lc17smp

Member
Sep 19, 2019
44
19
8
Real Name
Larry Cole
Installed the new throttle cable this weekend and put a protective sleeve on it. I rerouted the cable a little bit further away from the exhaust and with the heat sleeve hopefully I’ll be ok. As I was waiting for the cable to ship I also decided to put a tach on the 570. I installed a digital tach and also bought a laser rpm tool to verify the rpm tach was correct. Good thing I did as the directions on the tach will lead you to the wrong settings. After installing and verifying the tach I quickly realized that the 570 was spinning much slower than it’s capable of. Throttle adjustments have not been touched since purchase and cable was still pulling the throttle to the max. Max throttle was getting me about 2250 rpm’s. The Apex 570 should be set to 3000 rpm’s max. Gotta love my local supplier that I purchased it from. 30k purchase and can’t set something and critical as the rpm. According to the GD 408 spec sheet (blower) that equates to aprox 60 cfm difference. Who needs more cfm………

4CEEE781-A2B4-40FB-9DBB-4B778C958D8D.jpeg