saphire scientific 570 | TruckMount Forums #1 Carpet Cleaning Forums

saphire scientific 570

john P.

New Member
Jun 13, 2020
8
0
1
Real Name
John Paepke
lately I've been getting a half hour into the job and I lose pressure, and only get a mist coming from the wand.
I can usually restore pressure it by tinkering, like turning the pump switch on and off a couple times, wiggling hoses ect... its sorta getting old and would like to get to the bottom of it:)

anyone help me out? the pump is running during the pressure loss, sometimes very little water in the site glass.
 

mrg.mrg.

Active Member
Oct 15, 2014
595
92
28
35
Real Name
zamir mejia
Does that one have a water box? Have you opened waste tank when it's doing that? Water could be going out the bypass into waste tank or not enough water pressure from inlet or belts slipping or maybe one of the high pressure hoses is breaking down and needs replacing
 

mrg.mrg.

Active Member
Oct 15, 2014
595
92
28
35
Real Name
zamir mejia
Ask Our Repairmen it says....I'm still wondering who they are....almost no one ever answers
 

Justin Legend Brands

Expert Truckmount Mechanic
May 7, 2018
44
31
18
Real Name
Justin Johnston
lately I've been getting a half hour into the job and I lose pressure, and only get a mist coming from the wand.
I can usually restore pressure it by tinkering, like turning the pump switch on and off a couple times, wiggling hoses ect... its sorta getting old and would like to get to the bottom of it:)

anyone help me out? the pump is running during the pressure loss, sometimes very little water in the site glass.

Feel free to give me a call. 800-932-3030 and I am extension 4819. You can also ask for tech support.