ProChem Legend GT shuts down

IowaHealthyHomes

Active Member
Feb 13, 2011
116
36
28
Iowa
Real Name
Brad Hesseltine
Business Location
United States
For the last week my new GT keeps shutting down after start up around 10 minutes after running. I have to go out and restart it, and then it runs great for the whole job. Can’t figure out what would be causing this. Only 115 hours on the machine.

Any help would be appreciated. Thanks
 

rob allen

Administrator
Staff member
Administrator
Sep 5, 2007
33,928
16,411
113
Va.
www.drynclean.com
Real Name
Robert Allen,Jr.
Business Location
United States
Why did you buy the GT? Also does yours leak oil like the Valdez like mine?
 
Reactions: Chris Henry

OxiFreshGuy

Well-Known Member
Nov 12, 2016
358
294
63
Real Name
Matthew Frein
Business Location
United States
If it's under warranty have it checked out, most likely a sensor issue.
 

rob allen

Administrator
Staff member
Administrator
Sep 5, 2007
33,928
16,411
113
Va.
www.drynclean.com
Real Name
Robert Allen,Jr.
Business Location
United States
If it's under warranty have it checked out, most likely a sensor issue.
True. Maybe it's the dump shut off switch accumulating debris and making it shut off early.
 

OxiFreshGuy

Well-Known Member
Nov 12, 2016
358
294
63
Real Name
Matthew Frein
Business Location
United States
Seems like on a lot of new installs some of the wires somehow are improperly wired causing issues with sensors.
 

sbsscn

Well-Known Member
Sep 17, 2009
2,010
568
113
california
Real Name
Arm Ben
Business Location
United States
Interesting.

I had a similar issue on my 2018 SS370. turned out to be my waste tank shut off. But after my first 2 jobs it broke in and have never had any issues.