Pressure help!!! | TruckMount Forums #1 Carpet Cleaning Forums

Pressure help!!!

jsmithjr

Member
Dec 3, 2015
74
14
8
47
Real Name
jerry smith
I'll have my pressure set at 1200psi and after about 10min. It drops down to 900 and can't get it back to up unless I turn my mount off turn it back on. But it will do this every time. start it back up 1200 10min later 900. Please help. Thanks in advance.
 

CCWorks

Premium VIP
Jan 3, 2010
11,054
1,396
113
Michigan
Real Name
Greg
Business Location
United States
Sounds like you run through pully belts.
It maybe belt slippage,
or blockage in your inline, filters.
 
  • Like
Reactions: OneBlueSummer

OneBlueSummer

Active Member
Sep 30, 2012
222
102
43
Real Name
Charlie King
could be hair or somethign stuck in your regulator or pump or line or what ccworks seaid
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
8,614
3,370
113
Real Name
Randy Dockins
Business Location
United States
If the machine has a Dema solenoid or other type it could be opening up and draining water into your waste tank. My pressure drops some when mine opens. You might try and turn the temperature control up and down on your machine and watch the pressure after the machine gets hot. When you turn the dial down below whatever temp the machine has actually reached that solenoid should open and the pressure will drop some then go back up when you turn the temp dial back up. I can tell if my Dema is working correctly by doing that. It's possible yours could be opening and staying open. What are you setting the temperature at when this happens?

Another possibility is the pressure gauge is bad. Check to see if your pressure gauge is going all the way down to zero when the machine is off. It could be giving a false reading. Can you tell for sure that there is actually a drop in pressure at the tool? I'm guessing you're doing hard surfaces at that kind of pressure.
 
  • Like
Reactions: sbsscn

OxiFreshGuy

Well-Known Member
Nov 12, 2016
1,823
1,338
113
Real Name
Boris Johnson
Business Location
United States
If you dont know what an inline filter is you need to find someone local to teach you about the machine and maintenance of it.
 
  • Like
Reactions: CCWorks

LeeRoy

Well-Known Member
Feb 13, 2010
768
298
63
Arizona
Real Name
Lee Coking
Business Location
United States
I agree with ccworks. I'd look at the belt and possible slippage. Good luck
 

sbsscn

Well-Known Member
Sep 17, 2009
2,334
767
113
california
Real Name
Arm Ben
Business Location
United States
I agree with Randy.

Disconnect the bypass/Dema solenoid run machine and check. It could also be that your machine was never designed to go that high and is calibrated/adjusted to bypass if over 900 psi/ check with manufacturer on the specs of the machine. Regulator could also be bad/worn. might need to be rebuilt/serviced
 

Jim Davisson

Well-Known Member
Aug 23, 2016
4,113
4,937
113
Serving the greater Charlotte area
Real Name
James Davisson
Business Location
United States
This machine uses a capillary tube and parker skinner valve to launch heat to the waste tank. The system has an 01 jet continuously spraying in the water box, 1200 psi with the waste tank lid on and pulling full working lift with the pump working that hard is exceeding the hp your motor realistically can sustain.

If you are doing tile and "think" you need 1200 psi switch to pressure washer hose for 1 job and run at 800 psi and reevaluate things. Flow runs spinners #facts
 
Last edited: