No heat | TruckMount Forums #1 Carpet Cleaning Forums

No heat

jsmithjr

Member
Dec 3, 2015
74
14
8
47
Real Name
jerry smith
I'm using the rotovac shur-dry w my 370ss however, I'm getting zero heat when I use my wand the heat is fine. Thanks in advance.
 

Todd the Cleaner

Todd Cottino
Staff member
Administrator
Moderator
Premium VIP
Sep 4, 2011
22,846
14,926
113
48
Pahrump, Nevada, United States
www.toddscleaningservice.com
Real Name
Todd Cottino
Business Location
United States
Sounds like the machine can't keep up with the amount of water flow when using the rotary.

Has your waste tank been filling up faster than normal? Is your bypass valve possibly stuck open so it's dumping water all the time?
 

jsmithjr

Member
Dec 3, 2015
74
14
8
47
Real Name
jerry smith
Yes, I've been working on that. I had no heat at all and replaced Thermal relief valve and now my wand gets hot but it takes about an hour of cleaning before it does. I've been in the business for only 6yrs. and only recently working on my own TM. Any suggestions would be greatly appreciated. BTW thanks for responding.
 
  • Like
Reactions: StevenB.

ChampionCityCleaner

New Member
Oct 14, 2016
29
21
3
35
Real Name
Levi Lennie
Yes, I've been working on that. I had no heat at all and replaced Thermal relief valve and now my wand gets hot but it takes about an hour of cleaning before it does. I've been in the business for only 6yrs. and only recently working on my own TM. Any suggestions would be greatly appreciated. BTW thanks for responding.
When was the last time you descaled your machine?

When I bought my Tm it was used and wasn't putting out heat. I took off a couple fittings and the hx was so plugged with calcium and mineral buildup that the water was bypassing the hx all together. I did a serious descaling and now some days it seems like my wand is breathing fire into the carpet.
 

Todd the Cleaner

Todd Cottino
Staff member
Administrator
Moderator
Premium VIP
Sep 4, 2011
22,846
14,926
113
48
Pahrump, Nevada, United States
www.toddscleaningservice.com
Real Name
Todd Cottino
Business Location
United States
Yes, I've been working on that. I had no heat at all and replaced Thermal relief valve and now my wand gets hot but it takes about an hour of cleaning before it does. I've been in the business for only 6yrs. and only recently working on my own TM. Any suggestions would be greatly appreciated. BTW thanks for responding.
Give Rick Aranda a call. He is a Sapphire Rep and knows those machines inside and out. I'll PM you his number.
 

raw74

Well-Known Member
Mar 21, 2011
1,291
315
83
ga
Real Name
reggie
Business Location
United States
7
Sounds like the machine can't keep up with the amount of water flow when using the rotary.

Has your waste tank been filling up faster than normal? Is your bypass valve possibly stuck open so it's dumping water all the time?
Uk
I'm using the rotovac shur-dry w my 370ss however, I'm getting zero heat when I use my wand the heat is fine. Thanks in advance.
Sounds like the machine can't keep up with the amount of water flow when using the rotary.

Has your waste tank been filling up faster than normal? Is your bypass valve possibly stuck open so it's dumping water all the time?
 

jsmithjr

Member
Dec 3, 2015
74
14
8
47
Real Name
jerry smith
Thanks for all the Info. You guys Are awesome. I odered some descaler yesterday. I live in Washington (not hard water) however Its due. I also noticed the diverter shafts is stuck open. I manually shut it but it goes right back to being open. Sure that has a lot todo with it.