My truck mount won't heat

Wec

Active Member
Jul 31, 2012
563
131
43
45
Real Name
dustin denton
Try turning the temperature on the heat exchanger up and down when the machine is off and the key is turned on and see if it makes a clicking noise

It's probably the solenoid stuck open and just running water non stop throu the heat exchanger and not letting the water heat up

You can find the solenoid by just tracing the line from the waste tank were the water is coming out with the machine running

There should be a filters that is right before the solenoid that needs to be cleaned out on a regular schedule

If you take the solenoid apart to clean it just be very careful there is a spring that will fly away if you open it to fast with out holding the top of the solenoid very careful



Sent from my Nexus 6 using TMF Forums mobile app
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
9,219
3,825
113
Real Name
Randy Dockins
Business Location
United States
It does sound like your solenoid is either out or stuck open. Sometimes cleaning it out will solve it if the coil has not gone out. If the coil goes out you either need a new coil or a new valve. The thermal valve is just behind the front panel down low on the left unless they moved it. It will fill your tank up really quick too when they go out if it sticks in the open position, but you won't lose heat as bad or as noticeable as you do with an open solenoid. I also always notice loss of some pressure at the wand when the solenoid goes out. No loss of pressure with the thermal valve whatsoever.
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
9,219
3,825
113
Real Name
Randy Dockins
Business Location
United States
Here is a picture of the thermal valve. Doesn't sound like this is your problem, but I highly recommend keeping a spare one of these at all times. When they go out you'll be lucky to do one room w/o your waste tank filling up. It is top center of the picture.

100_0227.JPG
 

Joe cool

Well-Known Member
Jan 8, 2015
4,407
1,409
113
Real Name
Joe
My prochem unit on on the side of the water box and the hose goes to the top of the waste tank .
I cut some clear plexiglass for the waste tank , started it up and watched ir open up from start up and dump , it uses vacuum to pull it open at 180° temperature .
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
9,219
3,825
113
Real Name
Randy Dockins
Business Location
United States
Must be my problem as well. My tank has been filling non stop.

Sent from my SM-G930P using TMF Forums mobile app

I don't know which machine you have, but on my Boxxer I can see a fluctuation in pressure when I turn the temp dial up or down IF the solenoid is working. Example is if you set your temp at say 180 degrees. When the machine exceeds that temp the solenoid is engaged and you will see the psi drop a bit because it is letting off some of your hot water to keep the temp at 180 or whatever you have it set at. You can also turn the temp dial up or down and you should see the solenoid engage or disengage just by watching your psi gauge. If I notice a general drop in pressure and a big drop in water temp most often it's been solenoid related on my machine. If my thermal valve goes out I see no drop in pressure and will still get maybe 170 degrees water temp, but the waste tank will fill pretty quick. Last time it happened I barely got done with one room and the tank was full. The solenoid can fill the tank pretty quick too though if it goes out or gets stuck all the way open.