Losing Pressure | TruckMount Forums #1 Carpet Cleaning Forums

Losing Pressure

renew carpet

Member
Dec 14, 2019
81
21
8
Real Name
joseph blumberg
I have a Ninja 500psi only 5 months old. I run it at 350 psi using my rotovac rotary. Its fine, however when using the Bonzer and cranking up to 500psi, after an hour or so, I lose pressure to the point it just comes out in short bursts. then nothing at all. after it sits for 10 minutes or so its fine. any suggestions where to start looking to solutions? I dont think the jets are blocked because starting out its great until after an hour or so,. this has happened several times. looking for possible reasons to check. thanks
 

Ed Valentine

Well-Known Member
Oct 8, 2008
1,763
632
113
Michigan, USA
cross-american.com
Real Name
Ed Valentine
Business Location
United States
Possibilities:

1. Chinese QD"S or using two different manufactured QD's.

2. Restriction on inlet side of pump (ex: kinked hose)

3. PSI pump Drive motor not large enough

Most likely, one of those above.

Hope this helps.
Ed V
crossamericancorp.com
 

John LaBarbera

Preferred Vendor
Premium VIP
Sep 13, 2008
2,736
1,219
113
71
San Diego, Ca
www.mytee.com
Real Name
John LaBarbera
I have a Ninja 500psi only 5 months old. I run it at 350 psi using my rotovac rotary. Its fine, however when using the Bonzer and cranking up to 500psi, after an hour or so, I lose pressure to the point it just comes out in short bursts. then nothing at all. after it sits for 10 minutes or so its fine. any suggestions where to start looking to solutions? I dont think the jets are blocked because starting out its great until after an hour or so,. this has happened several times. looking for possible reasons to check. thanks
The jets on the bonzer exceed the flow capacity of your pump. 1) Remove some of the jets if you can. 2) call the pump company and ask them if the have a higher flow cam. ( this will likely reduce the psi capability of the pump) 3) change your jets to smaller orifices and lower your flow.
 

abooker

Member
Dec 18, 2019
32
2
8
Real Name
Andrae S Booker
I have a Ninja 500psi only 5 months old. I run it at 350 psi using my rotovac rotary. Its fine, however when using the Bonzer and cranking up to 500psi, after an hour or so, I lose pressure to the point it just comes out in short bursts. then nothing at all. after it sits for 10 minutes or so its fine. any suggestions where to start looking to solutions? I dont think the jets are blocked because starting out its great until after an hour or so,. this has happened several times. looking for possible reasons to check. thanks
Brand New, Never Used Carpet Cleaner/Water Extractor for sale, great for carpet cleaning or restoration business
  • I have a Water Claw (the real water claw)-brand new in the Box Never Used
  • I have a Prospector® PE5003 Carpet Extractor with Heat, 500 PSI, Dual 3‑Stage motors with (carpet wand) and all of the hoses and connectors- retail price for the machine alone is typically about $4,000, I'm asking much less
  • I'm asking for $1,800 for 5,000 dollars worth of Brand New Never Used Equipment everything you need included plus water claw
  • Please go ahead and google the prices you will never have a deal this good on Brand New equipment ever again
  • Some Pics attached - Serious inquiries only 201-824-6555 text first then call or email service@polished-restoration.com
 

Attachments