El Diablo Low Pressure

knapp9

New Member
Jul 15, 2015
3
0
1
Real Name
Doug Knapp
Guys,

I have an El Diablo with some issues. We just replaced the seals in the CAT pump but we're still getting low pressure. When I turn on the truckmount I get great pressure at first. However, after I let go of the trigger on the wand, i can't get the pressure to return. It will trickle but that's about it. I have checked all of my connections and I don't believe that I am sucking air. Could it be the check valves?

thanks!

Doug
 

knapp9

New Member
Jul 15, 2015
3
0
1
Real Name
Doug Knapp
Okay, we changed out the check valve and we have pressure. However, we lost the heat. Weird! Anybody have any idea what we did wrong? The heat was working before we changed out the check valve.
 

rob allen

Administrator
Staff member
Administrator
Sep 5, 2007
38,552
19,898
113
Va.
www.drynclean.com
Real Name
Robert Allen,Jr.
Business Location
United States
Now that is odd. Fuel fired or heat exchanger version?


Sent from my iPhone using TMF Forums
 

Ara Klujian

Moderator & TMF Repair Expert
Moderator
Premium VIP
Jun 19, 2008
3,347
265
83
46
Chicago, IL
www.peterklujiancarpet.com
Real Name
ARA KLUJIAN
Business Location
United States
It is unrelated to the check valves. It could really be a number of things that's causing this. Here are some points to look at. Flow switch, electrode spacing, air in the kero/diesel pump, wiring issue possibly a bad switch, pump fuel solenoid, transformer etc... Too many points to list