El Diablo loosing RPM | TruckMount Forums #1 Carpet Cleaning Forums

El Diablo loosing RPM

Prouddadx6

Member
Jan 4, 2010
136
1
18
Boulder Colorado
Real Name
Keith Wroblewski
Business Location
United States
My El Diablo is loosing RPMs after it runs four a couple hours. It will drop from 3100 down to 2700. The kunkle valve is only set to 11 and it is a Honda 24HP with around 900 hours. I started putting a blower in the van to circulate air but it still bogged down yesterday. Any ideas? I might pull the Kunkle valve apart again and clean it. I cleaned it about 2 months ago.

Thanks
 

OxiFreshGuy

Well-Known Member
Nov 12, 2016
1,239
999
113
Real Name
Matthew Frein
Business Location
United States
Did you check all the usual suspects yet ?
 

Prouddadx6

Member
Jan 4, 2010
136
1
18
Boulder Colorado
Real Name
Keith Wroblewski
Business Location
United States
Cleaned out both waste tank filters, replaced air filter. The odd thing is that it doesn't happen till it has been running for a couple of hours.
 

OxiFreshGuy

Well-Known Member
Nov 12, 2016
1,239
999
113
Real Name
Matthew Frein
Business Location
United States
Belts are good? No problems with the alternator? Coolant levels are good? Etc
 

Anderson

Well-Known Member
Aug 16, 2006
2,703
1,114
113
60
Belton Texas
i personally do not use one of those waste tank microfilters inside the tank......

havent used 1 in 6-8 years.....
but I do use an inline filter outside the tank.........

from experince those micro filters can clog up in 2-4 hours and are almost impossible to clean....
i usually have to use acid to clean them.....
 

Paul Selby

Well-Known Member
Apr 26, 2013
1,167
501
113
South Central........Tennessee
Real Name
Paul Selby
Business Location
United States
My El Diablo is loosing RPMs after it runs four a couple hours. It will drop from 3100 down to 2700. The kunkle valve is only set to 11 and it is a Honda 24HP with around 900 hours. I started putting a blower in the van to circulate air but it still bogged down yesterday. Any ideas? I might pull the Kunkle valve apart again and clean it. I cleaned it about 2 months ago.

Thanks

It sounds like a bad ignition coil. These engines will run on 1 cylinder. Could get hot and stop working. Check your spark plugs after it does it. My guess is that one of them will have gas on it and that is the side that the coil is bad on.
 
  • Like
Reactions: hatteraskings

OxiFreshGuy

Well-Known Member
Nov 12, 2016
1,239
999
113
Real Name
Matthew Frein
Business Location
United States
Would the alternator going bad cause it to loose RPMs? Ill check the belts
It depends on the design of the machine, I had a Blue Wave which was losing RPM's and it's because the idiot who took it off one time didn't bolt it back in securely so the belt was sometimes getting loose.
 

Paul Selby

Well-Known Member
Apr 26, 2013
1,167
501
113
South Central........Tennessee
Real Name
Paul Selby
Business Location
United States
It depends on the design of the machine, I had a Blue Wave which was losing RPM's and it's because the idiot who took it off one time didn't bolt it back in securely so the belt was sometimes getting loose.
If it’s a propane unit it has an alternator. Diesel fired have voltage regulators on the engine itself and the belts have no consequence on the engine performance
 

Ara Klujian

Moderator & TMF Repair Expert
Moderator
Premium VIP
Jun 19, 2008
3,304
243
63
44
Chicago, IL
www.peterklujiancarpet.com
Real Name
ARA KLUJIAN
Business Location
United States
Would the alternator going bad cause it to loose RPMs? Ill check the belts
Yes, if the battery is not maintaining a charge you can loose rpm and horsepower. What does the voltage read when the rpm's start to drop? You probably need to do a process of elimination to tackle this problem.