can any one give me a hand

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
ok i have a boxxer 421 and for some reason i cant find the problem on why is it dumping water as soon as you fire it up water starts to flow into the recovery tank ive clamp down on the line hi temp control 180 and water still flows into the tank then i clamp down on the line that gos to the dema solenoid and still water flows to the tank the unit runs good and dose the test with temperature adjustment when it hits its temp the pressure will drop then back up again the way its suppose to do also keep in mind that chemical jug is going empty fast these are the two things that are my issue its causing me very low heat and i dont even need to open the flow meter and it will draw chemical from the jug i already put a new diaphragm new hi temp180 valve also the two new check valve so my next move is to replace the 3 way valve can any one tell me whats going on thank you
 

mrotto

Well-Known Member
Sep 1, 2009
2,997
2,034
113
Wisconsin
Real Name
Paul Ottensmann
Business Location
United States
i had a problem like that on my Titan just after I bought it. the Thermal Valve was stuck open. While I was waiting for a replacement, I removed the fittings and plugged them. Not a problem since.
 

wandwizard

Randy Dockins
Premium VIP
Nov 12, 2008
9,043
3,716
113
Real Name
Randy Dockins
Business Location
United States
ok i have a boxxer 421 and for some reason i cant find the problem on why is it dumping water as soon as you fire it up water starts to flow into the recovery tank ive clamp down on the line hi temp control 180 and water still flows into the tank then i clamp down on the line that gos to the dema solenoid and still water flows to the tank the unit runs good and dose the test with temperature adjustment when it hits its temp the pressure will drop then back up again the way its suppose to do also keep in mind that chemical jug is going empty fast these are the two things that are my issue its causing me very low heat and i dont even need to open the flow meter and it will draw chemical from the jug i already put a new diaphragm new hi temp180 valve also the two new check valve so my next move is to replace the 3 way valve can any one tell me whats going on thank you
It sounds as if your thermal vale and your Dema solenoid are good. It sounds to me like the 3 way valve could be the culprit. When it goes bad it can allow the vacuum from the recovery tank which is used to Prime the chemical pump will just draw on it all the time even if it's turned off. It can also allow air into your chemical pump and then your high pressure pump on the machine. That sounds like what is happening on your machine. The vacuum from the waste tank is what the Prime side of the 3 way valve is connected to and that's how it primes your chemical pump when you turn the dial to Prime. It will empty your 5 gallon chemical container in no time and all your detergent or rinse goes into your waste tank. Does that sound like what's going on? If your thermal valve is new and you've confirmed your Dema is working that just about has to be it if you are seeing water dumped into your waste tank. A new 3 way should fix it. The only other things that cause water to be drawn out of the chemical jug are a bad diaphragm on the chemical pump or a bad check valve on the chemical pump. Neither of those would cause water to be dumped into the waste tank though.
 
  • Like
Reactions: mrotto

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
i want thank you for your reply today i had time to play with it and what i did was get my hi temp thermal vale and my dema vale and took it apart let it sit in vinegar with thermal vale i then lube up the inside the thermal vale press on it in and out did the same to the 3 way vale put it all back together fire it up no water is dumping in the recover tank any more runs great so i did this to all 3 at the same time so i dont know what one was the issue but im happy it works now
 

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
i had a problem like that on my Titan just after I bought it. the Thermal Valve was stuck open. While I was waiting for a replacement, I removed the fittings and plugged them. Not a problem since.
thank you for your reply i did end up takeing off the thermal vale and dema and 3 way vale and let them sit in vinegar lube them up put them back on and it works just fine now so thank you
 

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
ok i have a boxxer 421 and for some reason i cant find the problem on why is it dumping water as soon as you fire it up water starts to flow into the recovery tank ive clamp down on the line hi temp control 180 and water still flows into the tank then i clamp down on the line that gos to the dema solenoid and still water flows to the tank the unit runs good and dose the test with temperature adjustment when it hits its temp the pressure will drop then back up again the way its suppose to do also keep in mind that chemical jug is going empty fast these are the two things that are my issue its causing me very low heat and i dont even need to open the flow meter and it will draw chemical from the jug i already put a new diaphragm new hi temp180 valve also the two new check valve so my next move is to replace the 3 way valve can any one tell me whats going on thank you
 

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
hi im back again with water dumping into the waste tank as soon as you start the unit so i clamp the lines to block water from going to the waste tank to be able to locate the issue and still water flows to the waste tank so then turn the switch off pump clutch water stops can any please tell what it is that can be the problem also its still kind of pulling to much soap maybe its the pump its self i check everything the water is only coming from hi pressure system side please give me some input boxxer 421 thank manny
 

mannyclean

New Member
Jun 13, 2020
15
0
1
Real Name
manuel castrejon
i had a problem like that on my Titan just after I bought it. the Thermal Valve was stuck open. While I was waiting for a replacement, I removed the fittings and plugged them. Not a problem since.
hi my name manny im back with the water dumping in to waste tank i clamp down all lines one at a time and still dumping do you have the answer please help