Bruin 2 pressure issue | TruckMount Forums #1 Carpet Cleaning Forums

Bruin 2 pressure issue

EuroPad

New Member
Jun 25, 2019
7
0
1
Real Name
Patrick Lundy
Hi everyone, I have a Bruin 2 and for almost a year the maximum pressure I get is 400psi. I changed the Cat pump ...no change. Changed regulator and it worked fine for a week or so then riverted to same problem. Any ideas ?
 

mrg.mrg.

Active Member
Oct 15, 2014
595
92
28
35
Real Name
zamir mejia
Did you take the spring out of the pressure regulator. Sometimes they come with one you have to take off. Your pump maybe wasn't the issue. Maybe blockage in the lines or pressure manifold where the regulator goes. Maybe dumping water out of the bypass or belt slipping and not turning the pump at required speed.
 

EuroPad

New Member
Jun 25, 2019
7
0
1
Real Name
Patrick Lundy
Did you take the spring out of the pressure regulator. Sometimes they come with one you have to take off. Your pump maybe wasn't the issue. Maybe blockage in the lines or pressure manifold where the regulator goes. Maybe dumping water out of the bypass or belt slipping and not turning the pump at required speed.
 

EuroPad

New Member
Jun 25, 2019
7
0
1
Real Name
Patrick Lundy
I took spring out of regulator and don't think belt is slipping. After putting on new pump and regulator it worked perfectly for a week or so then suddenly started to give trouble again. I not using my chemical pump and the two hoses relevant t to that are just sitting at side of unit . Would air get in to pump as a result ?
 

mrg.mrg.

Active Member
Oct 15, 2014
595
92
28
35
Real Name
zamir mejia
That's odd. If you have the chemical pick up shut off it should be fine. Even if pump gets air in somehow it tends to work its way out when your working. Maybe the clutch on the pump slip...I'm not sure if that can even happen but worth checking. So once it drops to 400 psi it wont go higher if you turn regulator? I think something is staying open, maybe bypass solenoid. Is waste tank filling up any faster? What's temp doing when this is happening?
 

EuroPad

New Member
Jun 25, 2019
7
0
1
Real Name
Patrick Lundy
Solenoid not stuck open so waste tank isn't filling quicker than normal.Temperaturr behaving normally. I can't operate at high temps. Machine shuts down. Pressure only goes to 400psi however far I turn gauge.
 

Justin Legend Brands

Expert Truckmount Mechanic
May 7, 2018
46
33
18
Real Name
Justin Johnston
Feel free to give me a call. 800-932-3030 and I am at extension 4819. You can also ask for tech support.
 

mrg.mrg.

Active Member
Oct 15, 2014
595
92
28
35
Real Name
zamir mejia
Solenoid not stuck open so waste tank isn't filling quicker than normal.Temperaturr behaving normally. I can't operate at high temps. Machine shuts down. Pressure only goes to 400psi however far I turn gauge.
Temp should be going higher if lower pressure unless it's dumping water to regulate temp
 

Joe cool

Well-Known Member
Jan 8, 2015
4,304
1,370
113
Real Name
Joe
Your pump seals are going out . The pump in most cases just get weaker and weaker until your down to 60 psi.