370ss not getting water

Dougie "fresh-clean"

Active Member
Howdy, no tank, live supply from garden hose. I tested all the way through quick connections for water flow, and when I manually fill machine at the radiator cap opening the pump functions normally, until water box runs dry.

What is there between water inlet and water box that I can mess with?
 

AndyT

Active Member
So you are getting no water from the supply hose to the water box. If that is correct I believe there is a pressure regulator that controls the pressure going INTO the water box. That pressure regulator also has a screen in it. Check that , Brass just behind the front panel where you would hook up your garden hose to.
 

Pinosan

Premium VIP
Howdy, no tank, live supply from garden hose. I tested all the way through quick connections for water flow, and when I manually fill machine at the radiator cap opening the pump functions normally, until water box runs dry.

What is there between water inlet and water box that I can mess with?
disassemble the entire feeding line and remove the restriction
 

sbsscn

Well-Known Member
I just got the new version (2018 370ss) and today I had a similar experience. I ran the machine and bled to get hot water, all was well but then the water stopped! I checked the hose bib, it was on I have a water softner and there was no water at the machine I almost went nut, but then I saw a kink in the hose from the hose spigot to my softner and as soon as I straightened and removed kink all was well again, problem solved. Maybe this is the same for you?
 

Dougie "fresh-clean"

Active Member
No kinks. Ran same line to other TM, and it flows freely until here:



Only trickle coming through the inlet
Pressure regulator doo-dad hicky ma-bob.
 

AndyT

Active Member
Turn the screw on that regulator doo-dad hicky ma-bob counter clockwise, it may be turned to far in and actually shutting off your water. The tank with the radiator cap is your water box and will have a tube just under the radiator cap. Open up that valve until water comes out that tube and then turn it back in a 1/2 turn. Look in your manual for that regulator to if there is a break down of it and see if it has a screen also.
 

AndyT

Active Member
Can you bypass that regulator? That regulator only controls the pressure coming from the source so that it isn't higher than the rating on that radiator and be running out. If you bypass it that will tell you if that is the problem. Maybe you need a new regulator or take that one apart.
 

Dougie "fresh-clean"

Active Member
Junk in the screen... I was Leary of removing that black plastic nut in the picture... called Scott as Sapphire, walked through that last step to access screen, then re-assembly and re-adjustment.
 

sbsscn

Well-Known Member
Did that solve the problem?
I was going to mention to check the quick connects for you fresh water supply
 
Howdy, no tank, live supply from garden hose. I tested all the way through quick connections for water flow, and when I manually fill machine at the radiator cap opening the pump functions normally, until water box runs dry.

What is there between water inlet and water box that I can mess with?
I might have had a similar problem I don't remember what exactly it was but the solution was simple. Take a male connector that is not attached to anything else and plug it into water intake for the 370 the air will come out and that is it. Sometimes air gets accumulated somewhere and causes a problem.
 

Welcome

Welcome to the best carpet cleaning forum in the world!

Support

If you are in need of support, please use the live chat on the store for fast responses.

Top