2003 butler system not working properly | TruckMount Forums #1 Carpet Cleaning Forums

2003 butler system not working properly

Genoa2878

New Member
Jul 10, 2018
6
0
1
Real Name
Anthony quattropani
I have a wiring issue with my butler system. The butler corporation does not have any panel wiring diagrams to share. Here is my question, the engage switch lights green but has no bearing on starting the machine. The truck mount starts simply by turning the key. How do I fix the engage switch to start the machine properly? The switch has already been replaced as well as the soft start switch under the hood. Any ideas to fix this?
 

Genoa2878

New Member
Jul 10, 2018
6
0
1
Real Name
Anthony quattropani
I've done that, the clutch engages when the key is turned rather than when the engage switch is pressed. But the engage switch is showing power just not starting the machine. I can not find any evidence of wire tampering but I wouldn't know without a wiring diagram
 

Genoa2878

New Member
Jul 10, 2018
6
0
1
Real Name
Anthony quattropani
Also the truckmount is not supposed to start without the e brake engaged but this also has no bearing on my butler system starting
 

Jim Davisson

Well-Known Member
Aug 23, 2016
4,031
4,819
113
Serving the greater Charlotte area
Real Name
James Davisson
Business Location
United States
Here's my thoughts on your situation.

Your main power should come off the key and be distributed from there. The lighted engage rocker switch should have at least three wires, power in from the main, a ground for the switches light and the power out wire (load) to the clutch. The switch will light even if it doesn't have a load on it. I believe someone has wired the clutch directly to the key for whatever reason.

The e brake safety switch has been bypassed either for operator convenience or was faulty and bypassed.