Search results | TruckMount Forums #1 Carpet Cleaning Forums

Search results

  1. Olivero

    Tennant R3 Machine, Complaint is "Not enough vacuum"

    We recently replaced the rollers, we put brand new ones in and they came back and said the carpet is still wet, I also think they are lowering the brushes too much to where they are grinding the brushes into the carpet rather than just slapping it around. They probably don't know this, I think...
  2. Olivero

    Tennant R3 Machine, Complaint is "Not enough vacuum"

    That makes a lot of sense, the vacuum shoes never hit the carpet, only the brushes. I've checked all the hoses and if I pull the shoe off and check the suction of that vacuum line, it's strong, so I don't think the problem is the vacuum, but it would make sense that it's just too much water...
  3. Olivero

    Tennant R3 Machine, Complaint is "Not enough vacuum"

    Very interesting, it has vacuum boots so the vacuum is actually on the brushes, (there's 2) not directly on the carpet.
  4. Olivero

    Tennant R3 Machine, Complaint is "Not enough vacuum"

    Thank you for the response I've checked all the filters I could find, there's not really any on the vacuum line itself, only on the spray line. If I hold my hand over the vacuum hose, it sucks really well, I mean it seems strong to me, It's gotta be the nozzle leaking out, I can't imagine it...
  5. Olivero

    Tennant R3 Machine, Complaint is "Not enough vacuum"

    Hello Everyone, as a disclaimer, I don't have any truck mounted equipment, I deal with in the building stuff only. This is my first post here, as a little background, I work for a company who has a large amount of equipment on site, I'm an in-house tech and I do pretty much anything that's...