HYDRAMASTER TITAN 875 PROBLEMS WITH GENERAL PUMP HTS2016S

Discussion in 'Hydramaster' started by robcleaner60, Apr 26, 2011.

  1.  
    robcleaner60

    robcleaner60 New Member

    Joined:
    Apr 22, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Occupation:
    owner
    Location:
    CA
    Ratings:
    +0 / 0 / -0
    Real Name:
    robert strickland
    Business Location:
    United States
    I BOUGHT THIS MACHINE APPORX. 5 MONTHS AGO. AFTER USING IT THE FIRST DAY THE EMPEROR PUMP MADE A SQUEELING NOISE AT IDLE. AFTER THREE NEW PUMPS FROM HYDRAMASTER I STILL HAVE A PUMP THAT IS SO NOISEY YOU CAN HEAR IT OVER THE MACHINE ROAR AND ESPECIALLY AT IDLE. WOULD APPRECIATE SOME FEEDBACK FROM TITAN OWNERS!
  2.  
    bcs

    bcs Member

    Joined:
    Mar 6, 2010
    Messages:
    222
    Likes Received:
    3
    Trophy Points:
    18
    Occupation:
    carpet cleaner
    Location:
    nz
    Ratings:
    +55 / 0 / -0
    Real Name:
    marcus barker
    Business Location:
    New Zealand
    hi Rob i have had titan for awhile now but do not have this problem.can only think of checking condition and tightness off pump belts regarding the squeeling noises?sorry cant help much.all the best
  3.  
    Dr Cleaning

    Dr Cleaning Active Member

    Joined:
    Jun 19, 2008
    Messages:
    970
    Likes Received:
    56
    Trophy Points:
    28
    Occupation:
    owner
    Location:
    Cherry Hill NJ
    Ratings:
    +213 / 0 / -0
    Real Name:
    Neil Lapinson
    Also check how straight the belt alignment is Very important
  4.  
    chevy4wd

    chevy4wd Member

    Joined:
    Oct 15, 2010
    Messages:
    309
    Likes Received:
    0
    Trophy Points:
    16
    Occupation:
    Business owner/ Teacher
    Location:
    California, Sacramento/ Elk Grove
    Ratings:
    +49 / 0 / -0
    Real Name:
    R. Guzman
    Business Location:
    United States
    Are you positive that the squealing is comming from the pump??? Kinda sounds like a bearing to me. How bout the blower? Have you greased the zirk fittings lately? After changing the pump 3 times and the noise still there, to me it sounds like something other than the pump.

    Ranier
  5.  
    bcs

    bcs Member

    Joined:
    Mar 6, 2010
    Messages:
    222
    Likes Received:
    3
    Trophy Points:
    18
    Occupation:
    carpet cleaner
    Location:
    nz
    Ratings:
    +55 / 0 / -0
    Real Name:
    marcus barker
    Business Location:
    New Zealand
    Ranier yes does sound like a bearing perhaps?blower has oil bath both ends no grease fittings however does have an idler pulley tensioner that must spin on a bearing maybe try lubrication on that bearing?
  6.  
    chevy4wd

    chevy4wd Member

    Joined:
    Oct 15, 2010
    Messages:
    309
    Likes Received:
    0
    Trophy Points:
    16
    Occupation:
    Business owner/ Teacher
    Location:
    California, Sacramento/ Elk Grove
    Ratings:
    +49 / 0 / -0
    Real Name:
    R. Guzman
    Business Location:
    United States
    Hmmm?? What type of blower comes on that unit?

    Ranier
  7.  
    cornerstone1

    cornerstone1 New Member

    Joined:
    Oct 10, 2010
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    AZ
    Ratings:
    +6 / 0 / -0
    Real Name:
    Ed Krutel
    Business Location:
    United States
    saw one like this a few years ago. they changed the belts three times. turns out that there was a piece of plastic on the disk in vacuum relief valve. You would have thought that a belt or bearing was bad from the horendous noise it was making
  8.  
    bcs

    bcs Member

    Joined:
    Mar 6, 2010
    Messages:
    222
    Likes Received:
    3
    Trophy Points:
    18
    Occupation:
    carpet cleaner
    Location:
    nz
    Ratings:
    +55 / 0 / -0
    Real Name:
    marcus barker
    Business Location:
    New Zealand
    Tuthill5009 Competitor Plus SL (dual splash)
  9.  
    bensurdi

    bensurdi Active Member

    Joined:
    Oct 6, 2008
    Messages:
    878
    Likes Received:
    27
    Trophy Points:
    28
    Occupation:
    Owner
    Location:
    Seattle, WA
    Ratings:
    +114 / 2 / -0
    Real Name:
    Ben Surdi
    Business Location:
    United States
    I am having the SAME problem with my brand new Titan 875. Anyone figure out what exactly is causing it? Obviously its an issue that is experienced on this machine over and over. You'd think that they would have figured it out.
  10.  
    letchworth

    letchworth Member

    Joined:
    Jan 31, 2010
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Greenville NC
    Ratings:
    +1 / 0 / -0
    Real Name:
    Lee
    Business Location:
    United States
    875 it a peace of junk being nice bought new in June 2010 had to replace in Aug. 2010 and had to replace waterbox,gages,waterpump, and the heater exchanger started to leak and now blower leaks oil only 1040 hrs warranty will not cove as it went out in June of 2012
  11.  
    crash1big

    crash1big Well-Known Member

    Joined:
    Mar 18, 2011
    Messages:
    2,358
    Likes Received:
    575
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    owner operator
    Location:
    Illinois
    Ratings:
    +1,503 / 5 / -0
    Real Name:
    Marlan Brown
    Business Location:
    United States
    How about the clutch? Could it be the bearing in that? :)

Share This Page

Users found this page by searching for:

  1. Tut hill blower problems hydramaster x875

    ,
  2. emperor pump hts2016s